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Preface 

This manual provides information needed to understand and use the Indian Health 
Service (IHS) Clinical Scheduling for Windows (BSDX) package. The IHS Clinical 
Scheduling for Windows package is based on a graphical user interface (GUI) for 
scheduling appointments. 

This manual contains reference information about the IHS Clinical Scheduling for 
Windows package, examples of its processes, and procedures to perform the activities 
supported by the package. Step-by-step procedures are provided to aid in use of the 
IHS Clinical Scheduling for Windows package. 

Security 

The IHS Clinical Scheduling for Windows (BSDX) uses security keys to limit user’s 
ability to change system set-up parameters and patient information. Therefore, not all 
features are available to all users. Contact the site administrator to determine or 
change security keys. 

Rules of Behavior 

All Resource and Patient Management System (RPMS) users are required to observe 
Department of Health and Human Services and IHS Rules of Behavior regarding 
patient privacy and the security of both patient information and IHS computers and 
networks. This document provides both RPMS and BSDX Rules of Behavior. 
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1.0 Introduction 
Indian Health Service (IHS) Clinical Scheduling application for Windows (BSDX) is 
the Graphical User Interface (GUI) for the Resource and Patient Management System 
(RPMS) Patient Information Management System (PIMS) application It provides 
appointment management functions included in PIMS Scheduling, with the added 
convenience and usability of a GUI. The IHS Clinical Scheduling for Windows 
(BSDX) package should be used with PIMS Scheduling. 

1.1 Using This Manual 
If this package was just installed at your site, it must first be set up before the 
scheduling of patients can begin. Refer to Setting Up and Administering BSDX for 
instructions. 

If you need help understanding the screen layout or how to log on or off, refer to 
Orientation, or Getting Started, for more specific instructions. 

If the IHS Clinical Scheduling for Windows (BSDX) package was previously 
installed at your site and it has be upgraded for this version, you can schedule patients 
as described in Managing Patient Appointments, or view and print schedules as 
described in Viewing and Printing. 
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2.0 Orientation 

2.1 Definitions 
The table below defines terms used in this document for various areas of the user 
interface. 

2.1.1 Screen Area Descriptions Table 

Term Description 

Access Block Access Blocks are color-coded representations of the amount of time 
allotted for a specific Access Type (or appointment). 

Access 
Types 

Access Types refers to the variety of different appointment types 
available in the RPMS system. Each type of appointment, such as 
routine physical, dental, walk-in, or other specific appointment type is an 
Access Type. 

Access 
Groups 

Access Groups are categories of Access Types. Assigning Access 
Types to Access Groups makes it easier to schedule and search for 
certain types of appointments. 

Resources The term “resources” refers to any person or service for which a patient 
can be scheduled. Resources can be physicians, diagnostic equipment 
(such as MRI, CT scan, ultrasounds, and so on), or specialty 
appointment slots, such as physical therapy. 

Resource 
Groups 

Resource Groups are categories of resources that help to organize the 
variety of Resources available at each location. 

Slot Number of appointments per defined appointment length. For example, 
If SLOTS = 4 and the clinic (resource) appointment length is 30 
minutes, then there are 4 available appointments for every 30 minutes. 

 
See Setting Up and Administering BSDX for information regarding Resource and 
Access variables. 

2.2 Clinic Display Area 
The clinic schedule area is composed of date columns and time rows. Each column 
represents a day and each row represents a time interval. The time intervals can be 10, 
15, 20, or 30 minutes. The time interval can be changed using the View menu. For 
more information about Time Scale, see Changing the View. 



Clinical Scheduling for Windows (BSDX) Version 3.0 

User Guide Orientation 
April 2011 

3 

Access Blocks (areas of the schedule which are available for patient appointments) 
are indicated by the adjacent appointment times and dates. They may be color-coded 
to user preference. Different colors represent different Access Types. Position the 
cursor in the area and click on the schedule display. The type of clinic access and the 
number of appointment slots available are visible in a message in the status bar at the 
bottom of the scheduling window. Clinic Access Types and colors can be defined and 
changed by the administrator of the scheduling package. See Setting Up and 
Administering BSDX for more information. 

Patient appointments are displayed on the schedule as white boxes containing a 
patient name and a note (if applicable). 

 
Figure 1: Desktop with patient appointments and multiple clinic schedules 

2.3 Basic Screen Layout 
The basic 5-day appointment window is shown below. At the far left is a menu tree 
view showing the resources organized by Resource Group. In this example, the 
expanded view of Cardiology group shows three resources. 

The colors on the schedule display correspond to various Access Types, set up for 
this resource. The resources, Resource Groups, Access Types, and colors can be 
customized to the individual clinic. You can create your own Access Types, Resource 
Groups using the Scheduling Management window. See Using the Scheduling 
Management Window for detailed instructions. 
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Figure 2: Basic Screen layout 

2.3.1.1 Screen Area Descriptions Table 

Screen Item Description 

Title Bar Shows user ID and facility location in the upper left corner of the 
screen. 

Menu Bar Appears below the Name and location of current user. The 
available text menus are: File, Appointment, View, and Help. 

Tab Strip Shows open schedules/windows as selectable tabs. 

Resource 
Group Pane 

Appears at the far left of the screen, below the menu bar. Displays 
the available resources. 

Times Appears at the left side of the screen. Times are shown by hour 
and then by segment. They are listed in military time (for example, 
13:00 equals 1:00 p.m.).  

Resource Name Appears in the upper left side of the screen, immediately above 
the Times column. Displays the name of the Resource currently 
active in the client window. 

Client Window Area on your screen that shows the work space for an application. 

Appointment 
Date Selector 

Appears in the upper right corner of the screen, below the 
Minimize, Maximize, and Exit buttons. The date selected is the 
starting date of the appointments currently displayed in the client 
window. The range of appointments displayed can be 1-day, 5-
day, or 7-day. 

Minimize, 
Maximize, and 
Exit 

Appears in the uppermost right corner of the screen. These 
buttons function just as they do in the MS Windows applications. 
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Screen Item Description 

Scroll Bars, 
Box, and 
Arrows 

Appears at the far right side and at the bottom of the screen. 
These buttons function just as they do in MS Windows 
applications. 

Colors Displays Appointments using colors found in the Client Window 
area on the Schedule corresponding to the various Access Types 
that can be set up for a particular provider. 

2.4 Using the Resource Group Pane 
The Resource Group pane on the left side of the screen lists Resources and Resource 
Groups. If there is a Maximize icon (+), click it to expand the resource group to see 
available resources. Click the Minimize icon (-) to collapse the group. 

2.5 Dialog Boxes 
Dialog boxes appear when the application requires information from the user or when 
an error occurs. Most error dialog boxes ask you to click OK or Cancel to 
acknowledge the error. 

2.6 Viewing Long/Wide Reports 
When information extends beyond the bottom of the screen, a vertical scroll bar on 
the right side of the screen becomes active. Click the Up and Down Arrows on the 
scroll bar to view the previously hidden portions of the report or screen. Likewise, if 
the screen information extends beyond the right side of the screen, the horizontal 
scroll bar on the bottom of the screen becomes active. Click the Left and Right 
Arrows on the scroll bar to view the previously hidden portions of the report on the 
screen. 

 
Figure 3: View menu 
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2.6.1 1-Day View 

 
Figure 4: 1-Day Schedule View Screen 

2.6.2 5-Day View 

 
Figure 5: 5-Day Schedule View Screen 
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2.6.3 7-Day View 

 
Figure 6: 7-Day Schedule View Screen 

2.7 Changing the View 
The schedule can be viewed in five modes:  

• Patients Without Appointments (Walk-ins) 

• Cancelled Appointments 

• 1-Day 

• 5-Day 

• 7-Day 
The Display Cancellations shows all cancelled appointments for a clinic when 
checked. The 1-Day mode provides maximum detail for a single day schedule. The 5-
Day and 7-Day modes provide a view of 5 or 7 days of the schedule from the selected 
date. Use the View menu to change viewing modes. 

2.8 Appointment Window 
The appointment window displays the patient name, Health Record Number (HRN), 
time of appointment, and notes. Figure 7: Appointment Window shows an 
appointment made for the 10:00–10:15 time slots for TEST,ANGELA. When an 
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appointment is made, the appointment information is stored in the RPMS scheduling 
package. 

 
Figure 7: Appointment Window 

2.9 Resource Group View 
Figure 8: Viewing a Resource Group shows an entire group of resources for one day; 
the appointment window for the cardiology group displays all three resource 
schedules for June 25th. An appointment can be dragged from one resource to another 
or from one time slot to another. 

To view a Resource Group’s schedule: 

1. Right-click a Resource Group. 

2. Click Open Schedule. The Resource Group schedule displays. 
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Figure 8: Viewing a Resource Group 
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3.0 Getting Started 
This section provides instructions for accessing and exiting the Clinical Scheduling 
application, as well as an overview of the menus and commands available from the 
application menu bar. 

3.1 Logging On to the System 
To start using the Scheduling application: 

1. Select IHS Clinical Scheduling using the Start menu or double-click the IHS 
Clinical Scheduling desktop icon. 

 
Figure 9: Shortcut icon for scheduling 

The splash screen and RPMS Login window displays. 

 
Figure 10: RPMS Login window 

Note:  This application requires an RPMS account. If you do not 
have one, contact your supervisor or site administrator. 

2. Enter your user access code in the RPMS Access Code field. 

3. Enter your verify code in the RPMS Verify Code field. A window similar to the 
example below opens. 
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Figure 11: Initial view of the Clinical Scheduling application 

Patient appointments may be added, changed, or canceled. Refer to the specific 
sections of this manual for additional instructions. 

3.2 Logging Off 
To log off the IHS Clinical Scheduling application: 

Do one of the following: 

• If you are done scheduling appointments, select Close Schedule from the File 
menu. 

• If you receive a message similar to the one shown below, click OK and either 
quickly complete any tasks on which you are working or simply wait for the 
system to shut down Clinical Scheduling automatically. 

 
Figure 12: Shutdown warning message 

• If you receive a message similar to the one below, click OK. All users must click 
OK before the system can shutdown. All information entered into the system 
prior to the shutdown is saved.  
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Figure 13: System Shutdown Notification dialog box 

3.3 Menus and Commands 
Most MS Windows-compatible software toolbar menu commands duplicate the 
commands associated with the right-click menu. If a menu item is unavailable (or 
dimmed), it cannot be used. When performing specific operations, you must select the 
Resource, Appointment, or Patient you want before selecting a command. 

3.3.1 File Menu and Commands 
The example below shows the commands on the File menu and the paragraphs that 
follow describe each command’s function. 

 
Figure 14: File menu 

Open Multiple Schedules 

Use this command to open schedules for several or all resources. 

To open multiple schedules: 
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1. From the File menu, click Open Multiple Schedules. The Open Multiple 
Schedules window appears. 

 
Figure 15: Open Multiple Schedules window 

Select the Resource Group and Resources and click OK. Figure 16: Desktop with 
multiple schedules open shows multiple schedules open on a desktop. 
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Figure 16: Desktop with multiple schedules open 

Change RPMS Server 

Use this command to change the RPMS server. If schedules are open when this 
command is selected, the system prompts for confirmation to continue. Refer to 
Changing the RPMS Server for more information. 

Change RPMS Login ID 

Use this command to change the login ID. Refer to Changing Your Login ID for more 
information. 

Change RPMS Division 

Use this command to access another division from the Clinical Scheduling 
application. Click this command to open the window below, select another division, 
and click OK to access another division. 
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Figure 17: Select Division window 

Scheduling Management 

Use this command to open the Scheduling Management window. Refer to Using the 
Scheduling Management Window for more information. 

Print Clinic Schedules 

Use this command to access the Print Clinic Schedules window. Refer to Clinic 
Schedules for more information. 

Print Reminder Letters 

Use this command to access the Print Clinic Letters window. Refer to Reminder, 
Rebook, and Cancellation Letters for more information. 

Print Rebook Letters 

Use this command to access the Print Clinic Letters window. Refer to Reminder, 
Rebook, and Cancellation Letters for more information. 

Print Cancellation Letters 

Use this command to open a cancellation letter for a selected patient in the preview 
window. (Refer to Reminder, Rebook, and Cancellation Letters for more 
information). 

Print Patient Letters 
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Use this command to view all appointments for a selected patient in the print preview 
window. Refer to Printing Patient Letters for more information. 

Walk-In Report 

Use this command to access and print the walk-in patients list. 

Close Schedule 

Use this command to exit the Clinical Scheduling for Windows package. 

3.3.2 Appointment Menu and Commands 
Figure 18: Appointment menu shows the commands on the Appointment menu. 

 
Figure 18: Appointment menu 

New Appointment 

Use this command to create a new appointment. Refer to Making an Appointment for 
more information. 

Edit Appointment 

Use this command to edit an existing appointment. Refer to Editing Appointment 
Information for more information. 

Cancel Appointment 
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Use this command to cancel an appointment. Refer to Deleting Appointments for 
more information. 

Undo Cancel Appointment 

Use this command to undo the canceling of an appointment. 

Mark as No Show 

Use this command to indicate that a patient did not show up for an appointment and 
did not cancel it. Refer to Marking a No-Show Appointment for more information. 

Undo No Show 

Use this command to unmark an appointment as a no show. Refer to Undoing a No-
Show Appointment for more information. 

Copy Appointment to Clipboard 

Use this command to copy an appointment to the Appointment Clipboard which 
makes scheduling duplicate appointments faster. Refer to Using the Appointment 
Clipboard for more information. 

Create Walk-In Appointment 

Use this command to add a same-day appointment for a patient. 

Find Available Appointment 

Use this command to search the Scheduling system for an appointment that matches 
your criteria. Refer to Finding an Available Appointment for more information. 

Check In Patient 

Use this command to check a patient in when they arrive for an appointment. Refer to 
Checking In a Patient for more information. 

Delete Patient Check In 

Use this command to delete a patient check in. 

Check Out Patient 

Use this command to check out a patient. 

Undo Check Out Patient 

Use this command to reverse a check-out patient. 
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View Patient Appointments 

Use this command to view the appointments for a specific patient. Refer to Patient 
Appointments for more information. 

3.3.3 View Menu and Commands 
Figure 19: View Menu shows the commands on the View menu. 

 
Figure 19: View Menu 

1-Day View 

Use this command to view the schedule for a single day. This provides the most detail 
available. Refer to the 1-Day Schedule View Window. 

5-Day View 

Use this command to view the schedule for Monday through Friday. Refer to the 5-
Day Schedule View Window. 

7-Day View 

Use this command to view the schedule for the entire week. Refer to the 7-Day 
Schedule View Window. 

Time Scale 

This command sets the amount of time allotted for each appointment. The 
appointment interval can be customized to fit a clinic’s needs: 

• 10 minute 

• 15 minute 

• 20 minute 
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• 30 minute 

Schedule Tree 

This command shows or hides the Resource Group pane at the left side of the 
Scheduling window. 

Appointment Clipboard 

This command opens the appointment clipboard. Refer to Using the Appointment 
Clipboard for more information. 

3.4 Changing the RPMS Server 
To change the RPMS Server: 

1. Select the Change RPMS Server command from the File menu.  

2. Click OK in response to the prompt shown below. 

 
Figure 20: RPMS server confirmation message 

3. Type the appropriate RPMS Server Address, Port, and Server Namespace in 
the text boxes and click OK in the dialog box shown below. 

 
Figure 21: Changing the RPMS Server 
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3.5 Changing Your Login ID 
To change the RPMS Login ID: 

4. Select the Change RPMS Login command from the File menu shown below. 

 
Figure 22: File menu 

5. Click OK in response to the prompt. 

 
Figure 23: Changing the login 

6. Type the appropriate RPMS Access and Verify Codes in the text boxes and click 
OK. 
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Figure 24: Changing the Login 

3.6 Configuring Clinical Scheduling Roll-and-Scroll Application 
This section provides step-by-step instructions to configure the Clinical Scheduling 
Terminal Services program. 

3.6.1 Printer Configuration 
Follow the steps below to set up the default printer. Changing a default printer should 
be the responsibility of a supervisor or application super user.  

DEMO HOSPITAL 
 
   AL     Appointment List 
   AM     Appointment Management 
   CR     Chart Requests 
   CHK    List Patient Check In Status 
   DA     Display Patient's Appointments 
   MB     Multiple Appointment Booking 
   MC     Multiple Clinic Display/Book 
   MD     Month-at-a-glance Display 
   PL     Print Scheduling Letters 
   PS     View Provider's Schedule 
   WL     Waiting List Enter/Edit 
   PCP    Primary Care Provider Menu ... 
   PMR    Patient Mini Registration 
   SCR    Reports Menu (Scheduling) ... 
   SCS    Supervisor Menu (Scheduling) ... 
 
You have PENDING ALERTS 
          Enter  "VA to jump to VIEW ALERTS option 
 
Select Scheduling Menu Option: SCS  Supervisor Menu (Scheduling) 
 
Supervisor Menu (Scheduling) 
 
(DEMO HOSPITAL) 
   ACM    Application Coordinator Menu ... 
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   CPF    Clinic Profile 
   CRA    Cancel/Restore Clinic Availability 
   DSU    Display Scheduling User 
   EEL    Enter/Edit Letters 
   IWL    Wait List Activate/Inactivate 
   LAM    List Appts Made By Clinic 
   MON    Month-at-a-glance Display 
   SET    Set Up a Clinic 
 
You have PENDING ALERTS 
          Enter  "VA to jump to VIEW ALERTS option 
 
Select Supervisor Menu (Scheduling) Option: ACM  Application Coordinator 
Menu 
 
Application Coordinator Menu 
 
(DEMO HOSPITAL) 
 
   ACR    Add Cancellation Reasons 
   AEH    Add/Edit a Holiday 
   AWR    Add Waiting List Reasons 
   CHG    Change Patterns to 30-60 
   CVS    Create Visit Status Report 
   ESP    Edit Scheduling Parameters 
   IRC    Inactivate/Reactivate Clinic 
   KEY    View Scheduling Keys 
   OVB    Users with Overbook to All Clinics 
   PSD    Purge Scheduling Data 
   RMC    Remap Clinic 
   SCT    Scheduling Templates 
   VED    View Event Driver 
 
You have PENDING ALERTS 
          Enter  "VA to jump to VIEW ALERTS option 
 
Select Application Coordinator Menu Option: ESP  Edit Scheduling Parameters 
 
     Use this option to set up and maintain facility and system 
     parameters dealing with the Scheduling functions in PIMS. 
     There are 3 files involved. The MAS Parameter file has only 
     one entry and is used for system-wide items such as multi- 
     division yes/no and appointment search threshold. All other 
     parameters are based on facility and stored in either the 
     Medical Center Division or the IHS Scheduling Parameter file. 
 
Editing system-wide parameters: 
 
PRIMARY FACILITY NAME: DEMO// 
MULTIDIVISION MED CENTER?: NO// 
APPT SEARCH THRESHOLD: 1// 
 
Editing facility-wide parameters: 
 
Select IHS SCHEDULING PARAMETERS DIVISION: 1  DEMO     1946 
         ...OK? Yes//   (Yes) 
 
INSTITUTION FILE POINTER: DEMO HOSPITAL// 
FACILITY NUMBER: 1946// 
 
SCHEDULING PARAMETERS for DEMO                Page 1 of 2 
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OUTPATIENT ONLY (answer only if YES): 
 
      APPT LAB TEST START TIME: 
           APPT EKG START TIME: 
         APPT X-RAY START TIME: 
 
   ADDRESS LOCATION ON LETTERS: TOP 
 
REMOVE SALUTATION FROM LETTERS: 
  ASK LETTER DURING MAKE APPT?: NO 
ASK LETTER FORMAT W/MAKE APPT?: NO 
RESTRICT VIEW OF WHO MADE APPT: 
   WAITING PERIOD FOR NO-SHOWS: 
    PATIENT REGISTRATION EDIT?: 
    TERMINAL DIGIT CALCULATION: 
      REQUEST CHART AT CHECKIN: 
______________________________________________________________________ 
Exit     Save     Next Page     Refresh 
 
Enter a command or '^' followed by a caption to jump to a specific field. 
 
COMMAND: Next Page                              Press <PF1>H for help    
Insert 
 
SCHEDULING PARAMETERS for DEMO                Page 2 of 2 
 
FILE ROOM USES TERMINAL DIGIT?: YES   FILE ROOM LIST SORT: BY CLINIC NAME 
 
                       ROUTING SLIP FORMAT: SHORT 
       PRINT EXTRA ROUTING SLIP FOR CHART?: NO 
PRINT HEALTH SUMMARIES WITH ROUTING SLIPS?: NO 
                    WAITING PERIOD FOR AIU: 
                CHART REQUEST PRINT TIMING: 
     DEFAULT FOR PRINTING A RS ON WALK INS: 
   DEFAULT FOR WANT CHART REQ FOR SAME DAY: 
                    DEFAULT WALKIN PRINTER: 
          CHART REQUESTS FOR TODAY PRINTER: HFS 
             FUTURE CHART REQUESTS PRINTER: 
            DEFAULT HEALTH SUMMARY PRINTER: 
              ACTION PROFILE TERMINAL TYPE: 
              DEFAULT ROUTING SLIP PRINTER: 
______________________________________________________________________ 
 
COMMAND:                               Press <PF1>H for help    Insert 
 
********************************************************************** 

Figure 25: Select Main Menu > SCS > ACM > ESP >. Edit the field CHART REQUESTS FOR 
TODAY PRINTER: 

3.6.2 Overbook Configuration 
Follow the steps below to set up the Overbook Authority for a clinic.  

DEMO HOSPITAL 
 
   AL     Appointment List 
   AM     Appointment Management 
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   CR     Chart Requests 
   CHK    List Patient Check In Status 
   DA     Display Patient's Appointments 
   MB     Multiple Appointment Booking 
   MC     Multiple Clinic Display/Book 
   MD     Month-at-a-glance Display 
   PL     Print Scheduling Letters 
   PS     View Provider's Schedule 
   WL     Waiting List Enter/Edit 
   PCP    Primary Care Provider Menu ... 
   PMR    Patient Mini Registration 
   SCR    Reports Menu (Scheduling) ... 
   SCS    Supervisor Menu (Scheduling) ... 
 
 
You have PENDING ALERTS 
          Enter  "VA to jump to VIEW ALERTS option 
 
Select Scheduling Menu Option: SCS  Supervisor Menu (Scheduling) 
 
 
Supervisor Menu (Scheduling) 
 
(DEMO HOSPITAL) 
 
   ACM    Application Coordinator Menu ... 
   CPF    Clinic Profile 
   CRA    Cancel/Restore Clinic Availability 
   DSU    Display Scheduling User 
   EEL    Enter/Edit Letters 
   IWL    Wait List Activate/Inactivate 
   LAM    List Appts Made By Clinic 
   MON    Month-at-a-glance Display 
   SET    Set Up a Clinic 
 
 
You have PENDING ALERTS 
          Enter  "VA to jump to VIEW ALERTS option 
 
Select Supervisor Menu (Scheduling) Option: SET  Set Up a Clinic 
 
 
     Use this option to create clinics, modify their parameters, 
     and set up their appointment slots.  
 
 
Select CLINIC NAME: ?? 
 
Choose from: 
   CHART REVIEW 
   CT SCAN 
   CT SCAN 
   DAY SURGERY 
   DIABETES 
   LABORATORY 
   PEDIATRICS 
   PRENATAL 
   TELEPHONE 
   TEST CLINIC 
   ULTRA SOUND 
   WLTEST 
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   X-RAY 
 
        You may enter a new HOSPITAL LOCATION, if you wish 
        Name given by user to any ward, clinic, fileroom, operating 
        room or other location within a VA facility. 
 
Select CLINIC NAME: LABORATORY 
 
 
SET UP A CLINIC                       Page 1 of 4 
 
 CLINIC NAME: LABORATORY                        ABBREVIATION: LAB 
    DIVISION: DEMO                              FACILITY: DEMO HOSPITAL 
 
     MEETS AT THIS FACILITY?: YES 
  NON-COUNT CLINIC? (Y OR N): NO 
 INCLUDE ON FILE ROOM LISTS?: 
  PRINCIPAL CLINIC: 
 PHYSICAL LOCATION:                                   TELEPHONE: 
       CLINIC CODE: LABORATORY SERVICES 
  HOSPITAL SERVICE: MEDICAL 
CLINIC OWNERS (responsible for setup) 
HAGER,MARY G 
 
 
______________________________________________________________________ 
Exit     Save     Next Page     Refresh 
 
Enter a command or '^' followed by a caption to jump to a specific field. 
 
 
COMMAND: Next Page                     Press <PF1>H for help    Insert 
 
SET UP A CLINIC                       Page 2 of 4 
 
SPECIAL INSTRUCTIONS for make appt. (3 lines max.) 
 
 
   PROHIBIT ACCESS TO CLINIC?:                  OVERBOOK USERS & LEVEL 
        SCHEDULE ON HOLIDAYS?:                    USER,DEMO             R 
   HOUR CLINIC DISPLAY BEGINS: 8 
        LENGTH OF APPOINTMENT: 10 
  VARIABLE APPOINTMENT LENGTH: YES, 
  DISPLAY INCREMENTS PER HOUR: 10-MIN 
        OVERBOOKS/DAY MAXIMUM: 1 
MAX # DAYS FOR FUTURE BOOKING: 10 
   START TIME FOR AUTO REBOOK: 
   MAX # DAYS FOR AUTO-REBOOK: 10 
______________________________________________________________________ 
 
 
COMMAND:                               Press <PF1>H for help    Insert 

Figure 26: Main Menu > SCS > SET > SELECT Clinic NAME >. Select COMMAND: NEXT 
PAGE >. Edit the field OVERBOOKS/DAY MAXIMUM 
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4.0 Managing Patient Appointments 
This section provides instructions for scheduling, viewing, editing, canceling an 
appointment for a patient, as well as checking in a patient. It also provides 
instructions for using the Appointment Clipboard, which is useful when scheduling 
multiple appointments for the same patient.  

4.1 Opening or Viewing a Schedule for a Selected Resource 
This section provides instructions for opening or viewing an appointment for a 
patient. 

To view the schedule for a selected Resource: 

1. Select a Resource Group or individual Resource from the Resource Group 
pane. Expand and collapse the groups by clicking the Maximize icon (+) or 
Minimize icon (-) next to a group. 

2. Do one of the following: 

• Double-click the resource name and select Open Schedule from the File 
menu. 

• Right-click the resource name and select Open Schedule from the Resource 
Group pane. 

3. If desired, also view the schedule of all resources in a group by selecting the 
group and then double-clicking the group name. 

4.2 Finding an Available Appointment 
Users can search an entire Resource Group or specific resource within a group for an 
available appointment using Find Available Appointment. 

To find an available appointment for a Resource Group or individual Resource: 

1. Click the Resource Group or individual resource within a group on the Resource 
Group pane to find the available appointment. 

2. Do one of the following: 

• On the Appointment menu, click Find Available Appointment.  
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Figure 25: Find Available Appointment from File menu 

• Right-click on the resource in the Resource Group pane, then click Find 
Available Appointment.  

 
Figure 26: Finding an available appointment using context menu 

The Appointment Search window is displayed. 
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Figure 27: Available search options 

3. Select the search parameter using the options in the Search Parameters pane. 

 
Figure 28: Available search options 

• Figure 29: Date Range box shows the Date Range pane. Click and drag the 
cursor from the beginning date to the ending date of the range. The date range 
must be 14 consecutive days, or less. 
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Figure 29: Date Range box 

• Figure 30: Time of Day box shows the Time of Day pane. Select AM Only, 
PM Only, or Both. 

 
Figure 30: Time of Day box 

• In the Day of the Week pane, select the days of the week to find an 
appointment time. 

 
Figure 31: Day of the Week box 

• In Figure 32: Access Group box, select the appropriate Access Group from 
the drop-down list. 

 
Figure 32: Access Group box 

• In the Access Type pane, select all applicable Access Types for the 
appointment time. 
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Figure 33: Access Type box 

4. Click Search when finished selecting the search parameters. A list of available 
appointments is displayed in the Search Result box. 

 
Figure 34: Searching for an Available Appointment (Results) 

The order of the list can be changed by clicking any column heading in the search 
results. 

If there are multiple appointments available, scroll through the results list to find 
the correct one. To select an appointment, double-click any place on the row 
where that appointment appears. When selecting an appointment from the list, the 
Scheduling window opens to that date to make the appointment. Refer to Making 
an Appointment for instructions. 

• If there are no appointments available for the parameters selected, a message 
is displayed. 
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Figure 35: No Availability dialog box 

4.3 Making an Appointment 
This section provides instructions for making appointments for patients. 

To create a new appointment: 

1. Click-and-hold the cursor over an area of the schedule that is available for 
appointments as indicated by the Access Type color, and drag the cursor to cover 
the entire time range needed for the appointment. 

2. Do one of the following: 

• Click New Appointment from the Appointment menu. 

• Right-click on the selected area, then click Add Appointment. 
The Select Patient window is displayed. 

3. Select a patient by typing lookup information (Name, SSN, DOB, or HRN) in the 
Select Patient Search window. Enter the first part of the patient's last name, the 
last 4 digits of the SSN, the entire SSN, HRN, or the DOB in the M-D-YYYY 
format.  

 
Figure 36: Search Patient by DOB 
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4. Press Enter or click Search. If the system finds only one match, the fields are 
automatically populated in the Select Patient field. If there is more than one 
match, a list of available patients is displayed. To select from this list, double-
click the patient and then click OK to confirm the selection. 

Note: The last patient may be recalled by pressing the spacebar 
and then Enter. 

 
Figure 37: Making an Appointment 

The Patient Appointment window is displayed. 
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Figure 38: Patient Appointment window 

5. Use the Patient Appointment window to confirm the patient's contact 
information and to enter any relevant notes. The patient’s identification 
information shows in the Patient ID box, and the appointment information 
appears in the Appointment box. The user can also click the Contact 
Information tab to view the patient’s contact information. The Contact 
Information tab is read-only; any changes made are not saved. 

6. Click OK to enter this appointment in the schedule. 

If an appointment conflict exists for the patient, the conflicting appointment will 
show in the Appointment Conflicts pane of the Patient Appointment window. If 
this occurs, see Changing Appointment Times to change the appointment. 
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Figure 39: Conflict Notification in Patient Appointment window 

4.4 Editing Appointment Information 
This section provides instructions for editing appointments information. 

Note:  To change a patient’s appointment time, refer to Changing 
Appointment Times. 

To edit appointment information: 

1. Select the appointment to edit. 

2. Do one of the following: 

• Right-click the appointment and then click Edit Appointment. 

• Select Edit Appointment from the Appointment menu. 
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The Patient Appointment window displays. 

 
Figure 40: Patient Appointment window 

3. Edit the appointment information as appropriate. 

4.5 Changing Appointment Times 
This section provides instructions for changing the time of a patient appointment. 

To change an appointment time: 

1. Click-and hold the appointment box. 

2. Drag and drop the appointment to a new time slot. The IHS Clinical Scheduling 
dialog box displays. 
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Figure 41: IHS Clinical Scheduling dialog box 

3. Click Yes to confirm or No to cancel the move. 

4.6 Deleting Appointments 
This section provides instructions for canceling patient appointments. 

To cancel an existing appointment: 

1. Click the appointment that you want to cancel. 

2. Click Cancel Appointment in the Appointment menu. The Cancel 
Appointment dialog box displays. 

 
Figure 42: Cancel Appointment dialog box 
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3. Click the appropriate button to select whether the appointment was cancelled by 
the clinic or by the patient in the Appointment Cancelled By pane. 

4. Click the appropriate reason for the cancellation in the Reason for Cancellation 
(Select one) list. 

5. Type any comments or remarks as needed in the Remarks (Optional) pane. 

6. Click OK to cancel the appointment or click Cancel to keep the appointment and 
return to the schedule. 

4.7 Undoing a Cancelled Appointment 
This feature enables the user to undo an appointment that was cancelled by the clinic. 
The user will not be able to undo an appointment cancelled by the patient. 

To undo a cancelled appointment: 

1. Click the patient appointment to undo cancelled appointment. Make certain that 
there is a thick box around the patient name. 

2. Select Undo Cancel Appointment from the Appointment menu (or right-click). 

3. The selected appointment color changes from gray to white. 

If you try to undo an appointment that was cancelled by the patient, the following 
message will display: 

 
Figure 43: Undo Cancel Appointment message 

An appointment previously cancelled by a patient cannot be rebooked at the same 
date and time. As a work around, the user can create a new appointment using the 
time scale increments, such as 10 minutes later, and make a comment in the notes 
section. 

4.8 Marking a No-Show Appointment 
This section provides instructions for marking a patient as a No Show when there was 
no cancellation. 

To mark a patient appointment as a no show: 



Clinical Scheduling for Windows (BSDX) Version 3.0 

User Guide Managing Patient Appointments 
April 2011 

38 

1. Click the patient appointment to mark as a no show. Make certain that there is a 
thick box around the patient name. 

2. Choose Mark as No Show from the Appointment menu. The No Show 
Appointment window displays. 

 
Figure 44: No Show Appointment window 

3. Do one of the following: 

• To schedule another appointment for this patient, check Auto Rebook and 
change the Start time in Days and the Maximum Days as necessary using the 
arrows; choose an Access Type for the Rebooked Appointment as necessary; 
then click OK. The text and background colors change to show this patient as 
a no show. 

• To dismiss this window without scheduling another appointment, click 
Cancel. 

4.8.1 How No-Show Works 
The user is allowed to assign as many no shows to a patient as necessary. When an 
appointment is made for a patient, an error message displays explaining the number 
of no-shows exceeds the number of allowable no-shows, which is the preferred mode 
of operation. The user can view the patient’s list of no-shows by selecting View 
Patient Appointments under the Appointment main menu. 
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The number of no-shows allowed is set in PIMS Clinic Set Up and only applies to 
that particular resource. 

4.9 Undoing a No-Show Appointment 
This section provides instructions for changing a patient appointment from a no-show 
to booked. 

To unmark a patient appointment as a no-show: 

1. Click the patient appointment to unmark as a no-show. Make certain that there is 
a thick box around the patient name. 

2. Choose Undo as No Show from the Appointment menu. The No Show 
Appointment window displays again. The text and background colors change to 
show this patient as booked. 

 
Figure 45: No Show Appointment window 

4.10 Using the Appointment Clipboard 
This section provides instructions for using the Appointment Clipboard to set 
multiple appointments for a patient. This is an excellent tool when making several 
follow-up appointments at one time. 

To use the Appointment Clipboard: 
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1. Click Appointment Clipboard on the View menu after making an appointment. 
Refer to Making an Appointment for more information. 

The Appointment Clipboard pane is displayed on the right side of the screen as 
shown below. 

 
Figure 46: Using the Appointment Clipboard 

2. Click-and-drag the patient name to the Appointment Clipboard pane. 

3. Release the patient name inside the Appointment Clipboard pane. 

4. Click the patient name in the Appointment Clipboard pane. 

5. Drag the patient name to a new appointment. You can create as many 
appointments (in as many clinics) for this patient as necessary using this method. 

4.10.1 Removing a Patient Name 
The section provides instructions for removing a patient name from the Appointment 
Clipboard. 

To remove a patient displayed in the Appointment Clipboard:  

1. Select patient name to remove from the Appointment Clipboard. 

2. Right-click and select Remove Item. The selected name is removed from the 
Appointment Clipboard. 

4.10.2 Clearing the Appointment Clipboard 
The section provides instructions for removing all patient names from the 
Appointment Clipboard. 
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To remove all patients displayed on the Appointment Clipboard: 

1. Move the cursor to the Appointment Clipboard pane. 

2. Right-click and select Clear All. 

4.11 Checking In a Patient 
A PCC Visit is created in RPMS for the patient if this option is selected through 
PIMS. The text in the patient appointment box on the schedule appears green in color 
after the patient check in. 

To check in a patient: 

1. Click the appointment to check in. 

2. Do one of the following: 

• Click Check In Patient on the Appointment menu. The Appointment 
Check In window displays. 

 
Figure 47: Appointment Check In window 

• Right-click the patient appointment, and click Check In Patient. The 
Appointment Check In window displays. 
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The current time and date are displayed in the Check In Time box. To adjust 
the check-in information, select the component of the time field to change 
(month, day, year, hour, or minute). Next click the up or down arrows to 
adjust the value or manually type a new value. 

3. Click OK to check the patient in, or Cancel to cancel the check-in process. 

4.12 Delete Check In 
This feature allows the user to reverse the status of a patient mistakenly checked in. 
The color of the time slot selected changes from green to white. A white appointment 
indicates a patient’s appointment waiting to be checked in. 

To delete a check in: 

1. Highlight a colored time slot that is green. A green time slot indicates a checked 
in patient. 

2. Right-click the selected time slot and select Delete Check In. 

 
Figure 48: Delete Check In option 

3. Click OK. The selected appointments color changes from green to white. 

4.13 Check Out Patient 
This feature allows the user to check out a patient. A patient’s check out status is 
displayed with an orange appointment time slot. A patient may not be checked out in 
the future. 

To check out: 

1. Highlight an appointment time slot that is colored green. 

2. Right-click and select the menu option Check Out Patient. The Appointment 
Check Out window opens. 
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Figure 49: Appointment Check Out window 

3. With the correct Visit Provider shown, click OK. The Appointment Check Out 
window closes and the selected appointment color changes from green to orange. 

4.14 Undo Check Out Patient 
This feature enables the user to undo check out patient. A patient’s check out status is 
displayed with an orange appointment time slot. Patients cannot be checked out prior 
to the current date. 

To undo a check out: 

1. Select a patient appointment that is colored orange. 

2. Right-click and select the menu option Undo Check Out Patient. 
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Figure 50: Undo Check Out Patient 
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5.0 Viewing and Printing 
This section provides instructions for viewing and printing clinic schedules, patient 
letters, and patient appointments. 

5.1 Print Preview 
Select a print function, the Print Preview window opens after making your 
selections. Any button that is not available for selection is dimmed. 

 
Figure 51: Previewing a report 

The table below describes various items and portions of the print preview window 
shown in Figure 51: Previewing a report  

5.1.1.1 Screen Item Descriptions Table  

Screen Item Description 
Title Bar Shows the name of the current window. Appears in the upper left 

corner of the screen. In the Check Out Patient window figure above, 
Clinic Schedules is the current view. 

Toolbar Appears across the top of the screen, below the Title bar. Shows 
buttons that perform various tasks available from the Print Preview 
window. 
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Screen Item Description 
Resource Group 
Pane 

Appears in the left pane of the screen below the tool bar. Allows you 
to view Resource Groups. Use the plus and minus signs to expand 
or collapse the lists of Resources. 

Main Report Tab Appears at the top of the right page just below the print icon. Shows 
a printable view of a schedule or letter. 

Current Page 
No. 

Appears at the bottom-left of the screen. Shows the page number 
that is currently displayed. In the Check Out Patient window figure 
above, it is page 6. 

Total Page No. Appears at the bottom of the screen. Displays the total pages for the 
particular report. In the Check Out Patient window figure above, it is 
7. 

Zoom Factor Found at the bottom-right of the screen. Displays the current zoom 
factor of the current display. In the Check Out Patient window figure 
above, it is 100%. 

5.2 Toolbar Buttons 
The Toolbar Buttons table shows the Toolbar icon and its function. 

5.2.1.1 Toolbar Buttons Table 

Toolbar 
Icon Button Name Function 

 
Go to First Page This button takes the user to the first 

page of a multi-page report. 

 Go to Previous Page This button takes the user to the 
previous page of a multipage report. 

 
Go to Next Page This button takes the user to the next 

page of a multipage report. 

 
Go to Last Page This button takes the user to the last 

page of a multipage report. 

 
Go to Page This button takes the user to a specific 

page. When clicking this button, the Go 
to Page dialog box opens. To go to the 
desired page, enter that page number. 

 
Close Current View This button closes the current view. 

 Print This button prints the report. Use the 
Print dialog box to select the printer to 
use to print the report. 

 Refresh This button enables the user to update 
the selected report with the latest 
information. 

 Export Report This button enables the user to send the 
current report to another application or 
use another format such as Word (.doc), 
Excel (.xls), Adobe Acrobat (.pdf), or 
Rich Text (.rtf) formats. 
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Toolbar 
Icon Button Name Function 

 
Toggle Tree View This button enables the user to show or 

conceal the Resource Groups pane. 

 
Zoom Use the Zoom button to zoom in 

(enlarge), or out (shrink) the view of the 
report by clicking the arrow and 
selecting from the menu. 

 Search Text Use this button to find a word or phrase 
in the text displayed. When clicking the 
Search Text button, the Search Text 
dialog box is displayed. Enter the word 
or phrase in the Find What field, and 
then click Find Next. 

5.3 Printing 
This section provides instructions for printing clinic schedules, patient letters, and 
patient appointments. 

5.3.1 Clinic Schedules 
The Print Clinic Schedules command enables the user to print a clinic schedule, an 
entire Resource Group, or individual resources within a given Resource Group. 

To print a clinic schedule: 

1. Click Print Clinic Schedules from the File menu. The Print Clinic Schedules 
window, shown in Figure 52: Print Clinic Schedules , is displayed. 
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Figure 52: Print Clinic Schedules window 

2. Select a Resource Group from the Resource Group drop-down list. 

3. Double-click to select each individual resource or check the Select All Resources 
box to print resource schedules. 

4. Choose the Beginning Date and the Ending Date dates using the drop-down list. 

5. Click OK and the Print Preview window opens showing the clinic schedule.  
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Figure 53: Clinic Schedule example 

6. Use the Toolbar buttons to export, print, and view pages of the schedule. See 
Toolbar Buttons for more information. 

5.3.2 Reminder, Rebook, and Cancellation Letters 
The Print Clinic Letters command allows the user to print various patient letters. The 
text of the letter can be modified using the dialog boxes shown in Add New 
Scheduling Resource Dialog Box and Edit Scheduling Resource Dialog Box.  

To print reminder, rebook, and cancellation letters: 

1. Select Print Reminder Letters, Print Rebook Letters, or Print Cancellation 
Letters from the File menu. A window similar to the one below displays. 

Note: The Print Rebook Letters and Print Cancellation Letters 
windows contain the same choices. Only the window 
names are different. 
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Figure 54: Print Reminder Letter window 

2. Choose a Resource Group from the list under Resource Group. 

3. Double-click to select each individual resource or check the Select All Resources 
box to print the selected letter. 

4. Choose the Beginning Date and the Ending Date dates using the drop-down list. 

5. Click OK and the Print Preview window opens showing the selected letter. 
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Figure 55: Reminder Letter example 

6. Use the Toolbar buttons to export, print, and view pages of the reminder rebook, 
and cancellation letters. See Toolbar Buttons for more information. 

5.3.3 Patient Letters 
The Print Patient Letters command enables the user to view or print all appointments 
in all clinics for the selected patient. 

To print patient letters: 

1. Click Print Patient Letters on the File menu. The Select Patient window opens. 
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Figure 56: Select Patient window 

2. Enter the name of the patient in the Select Patient field and click Search. 

3. Select the patient, and then click OK. The Print Preview window opens. 

4. Use the Resource Group pane to view the list of the clinics in which the patient 
has appointments.  
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Figure 57: Patient Letter window showing all appointments in all clinics for the selected 

patient  

5.3.4 Patient Appointments 
The View Patient Appointments command enables the user to view or print, or view 
and print all appointments (future or past) for a single patient. 

To view a patient’s appointments: 

1. Click View Patient Appointment from the Appointment menu The Select 
Patient window displays. 

2. Select a patient by entering the name, SSN, DOB, or HRN in the Select Patient 
Search field. The user may enter the first part of the patient's last name, the last 4 
digits of the patient SSN, the entire SSN, or the patient's DOB in the form 
MM/DD/YYYY. 
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3. Click Search. If the system finds one or more matches, the fields in the Select 
Patient window are automatically populated with the appropriate data for each 
patient found. To select a patient from this list, double-click the patient name, and 
then click OK to confirm your choice. 

Note:  The user can recall the last patient by pressing the Spacebar 
and then the Enter key. 

5.3.5 Viewing the Waiting List Report 
To view a patient’s Waiting List Report: 

1. Select a patient appointment.  

2. Click Scheduling Management from the File menu The Scheduling 
Management window displays.  

 
Figure 58: Scheduling Management window 

3. Select the patient’s resource and click the Change button. The Edit Scheduling 
Resource window opens. 
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Figure 59: Edit Scheduling Resource window 

4. Select the Inactive check box and click OK. A screen similar to the resource 
window shown below displays. 
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Figure 60: Resource window 

5. Click Print Waiting List. The Waiting List Report opens. 

 
Figure 61: Waiting List window 



Clinical Scheduling for Windows (BSDX) Version 3.0 

User Guide Setting Up and Administering BSDX 
April 2011 

57 

6.0 Setting Up and Administering BSDX 
This section includes instructions for the following tasks: 

• Using the Edit Availability window to set up schedules using Access Blocks, 
Access Types, and templates. Refer to Using the Edit Availability Window. 

• Using the Scheduling Management window to set up Users and User Roles, 
Resources, Resource Groups, Access Types, and Access Groups. 

• Using the Scheduling Management window for importing schedules from other 
RPMS applications and performing administrative tasks such as viewing, 
communicating, and shutting down workstations. Refer to Using the Scheduling 
Management Window. 

6.1 Using the Edit Availability Window 
This section includes setting up new schedules for resources. To create a new 
schedule, the user must first define Access Blocks using the Edit Availability 
window as described in the following section. 

6.1.1 Accessing the Edit Availability Window 
Before appointments can be scheduled, the layout for a schedule must first be 
designed. This section provides instructions for creating schedules for a Resource 
using the Edit Availability window. 

Note: To use the Edit Availability window, the (IHS Clinical 
Scheduling) Resource user profile must include the Modify 
Clinic Availability setting. See your supervisor or IHS 
Clinical Scheduling administrator to change your profile. 

To access the Edit Availability window: 

1. Select a resource from the Resource Group pane that contains the resource whose 
availability is to change. 

2. Right-click the resource. 
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Figure 62: Setting up resource availability 

3. Click Edit Resource Availability. The Laboratory Availability window opens. 
This window is similar to the regular scheduling window, except it has a blue 
background.  

 
Figure 63: Edit resource availability 
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6.1.2 Menus and Commands 
If an option is unavailable (or dimmed), it cannot be used. When performing specific 
operations, the user must select an Access Block before selecting an option. 

6.1.2.1 File Menu and Commands 
Figure 64: File Menu shows the commands on the File menu. 

 
Figure 64: File Menu 

Apply Template 

Use this option to apply a saved template to create a schedule for a new resource. 
Refer to Applying a Scheduling Template Check for more information. 

Save Template 

Use this option to save a template so it can be used to create a new schedule with the 
same layout. Refer to Creating a Scheduling Template for more information. 

Scheduling Management 

Use this option to open the Scheduling Management window. Refer to Using the 
Scheduling Management Window for more information. 

Close 

Use this option to exit the Edit Availability window. 

6.1.2.2 Access Blocks Menu and Commands 
Figure 65: Access Blocks Menu shows the commands on the Access Blocks menu. 

 
Figure 65: Access Blocks Menu 

Add New Block 

Use this option to add a new Access Block that can be used to schedule appointments. 
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Remove Block 

Use this option to remove an Access Block. 

Edit Block 

Use this option to change the appearance of an Access Block. 

Prevent Access 

Use this option to prevent access to an Access Block. 

 
Figure 66: Prevent Access block 

6.1.2.3 View Menu and Commands 
Figure 67: View menu shows the commands on the View menu. 

 
Figure 67: View menu 
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1-Day View 

Use this option to create Access Blocks and a schedule for a single day. This provides 
the most detail available. Refer to the 1-Day Schedule View Window.  

5-Day View 

Use this option to create Access Blocks and a schedule for Monday through Friday. 
Refer to the 5-Day Schedule View Window. 

7-Day View 

Use this option to create Access Blocks and a schedule for the entire week. Refer to 
the 7-Day Schedule View Window. 

Time Scale 

This option sets the amount of time allotted for each appointment. You can customize 
the appointment time slot to fit the clinic’s needs: 

• 10 minute 

• 15 minute 

• 20 minute 

• 30 minute 

Access Block Clipboard 

This option opens the Access Block Clipboard. Refer to Using the Access Block 
Clipboard for more information. Use the Access Block Clipboard to create multiple 
copies of Access Blocks with the same hours and appointment time slots. 

6.1.3 Setting up Clinic Availability 
This section explains how to set up Access Blocks. Resource availability is set up 
using Access Blocks. Each Access Block covers a given time range and contains a 
defined number of time slots. Each block is reserved for a particular type of Access 
Group and Access Type. These options are only available using the Edit Availability 
window. 

6.1.3.1 Adding an Access Block 
To add an Access Block: 

1. Open the Edit Availability window by right-clicking a resource and selecting 
Edit Resource Availability, as shown in the figure Setting Up Resource 
Availability. 
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2. Select the date of the schedule using the drop-down calendar at the top right 
corner of the window. 

3. Click the preferred view (1-day, 5-day, or 7-day) from the View menu. 

4. Click Time Scale, and select a 10, 15, 20, or 30 minute interval. 

5. Click-and-drag the pointer to outline the time range of the Access Block. The time 
range is displayed in the status bar at the bottom of the schedule. 

6. Do one of the following: 

• Click Add New Block on the Access Blocks menu. 

• Right-click on the selected block, then click Add New Access Block. 
Figure 68: Adding an Access Block displays the Access Block option. 

 
Figure 68: Adding an Access Block 

7. Select the number of appointments that can be made per defined appointment 
length in the Access Block from the Slot list, the Access Group from the Access 
Group list, and the Access Type from the Access Type list. For example, if 
SLOTS = 4 and the resource has a defined appointment length of 15 minutes, then 
there are four (4) available appointments for each 15 minute appointment time. 
Type any notes pertaining to this particular Access Block in the Note field. 

8. Click OK to save the new Access Block, or click Cancel to discard your 
selections and return to the Edit Availability window 

9. Continue adding Access Blocks, or exit and close this window 
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6.1.3.2 Editing an Access Block 
The following procedure provides instructions for editing an Access Block. 

To edit an Access Block: 

1. Open the Edit Availability window by right-clicking a resource and selecting 
Edit Resource Availability, as shown in the figure Edit Resource Availability. 

2. Click an Access Block. 

3. Do one of the following: 

• Click Edit Block on the Access Blocks menu. 

• Right-click on an Access Block, and then click Edit Access Block. 

4. Edit the following items as necessary: 

• Change the number of appointments per hour in the Access Block using the 
Slot list. 

• Change the Access Group using the Access Group list. 

• Change the Access Type using the Access Type list. 
5. Edit the notes pertaining to this particular Access Block in the Note field, as 

necessary. 

6. Click OK to save the changes to the Access Block, or click Cancel to discard the 
changes and return to the Edit Availability window. 

7. Continue editing or adding Access Blocks, or exit and close this window. 

6.1.3.3 Deleting an Access Block 
To delete an Access Block: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in the Setting Up Resource Availability. 

2. Click an Access Block. 

3. Do one of the following: 

• Click Remove Block on the Access Blocks menu. 

• Right-click on an Access Block and then click Delete Access Block. 
The IHS Clinical Scheduling dialog box displays. 
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Figure 69: IHS Clinical Scheduling dialog box 

4. Click Yes to confirm deletion of the Access Block, or click No to cancel the 
deletion. The Edit Availability window is redisplayed and the selected Access 
Block is removed. 

5. Continue adding, editing, and deleting Access Blocks, or exit and close this 
window. 

6.1.4 Using the Access Block Clipboard 
The Access Block Clipboard allows a user to duplicate Access Block by copying and 
pasting Access Blocks temporarily stored on the Access Block Clipboard. This 
feature is useful if adding several identical Access Blocks. An unlimited number of 
Access Blocks in the clipboard can be stored. However, the Access Block Clipboard 
is cleared when exiting the Edit Availability window. 

To use the Access Block Clipboard: 

1. Open the Edit Availability window by right-clicking a resource and choosing 
Edit Resource Availability, as shown in the figure Setting Up Resource 
Availability. 

2. Click Access Block Clipboard on the View menu. Figure 70: Using the Access 
Block Clipboard shows the Access Block Clipboard. 

3. Add a new Access Block as described in Adding an Access Block or click an 
existing Access Block. 

4. Drag the Access Block to the Access Block Clipboard. This does not move the 
Access Block; instead it copies the Access Block information to the clipboard. 

A new Access Block can be created on any area of the schedule by clicking and 
dragging the information to the new day and time. There is no limit to how many 
times a user can copy the Access Block to the schedule. 
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Figure 70: Using the Access Block Clipboard 

6.1.5 Using Templates to Set Up Resources 
Access Block templates are an excellent way to help set up a resource appointment 
schedule. Templates can be for one, five, or seven days. Once created, templates may 
be applied to the schedule repeatedly. Schedule Template files have a .bsdxa file 
extension. For example: pedstemplate.bsdxa for a pediatric clinic schedule or 
15mintemplate.bsdxa for Resources that use a 15-minute appointment slot. 

6.1.5.1 Creating a Scheduling Template 
This section provides instructions for creating a Scheduling Template. 

Note:  A 1-, 5-, or 7-day template can only be applied for the same 
time interval, (for example, apply a 1-day template to a 1-
day schedule). 

To create a template: 

1. Open the Edit Availability window by right-clicking a resource and selecting 
Edit Resource Availability, as shown in the figure Setting Up Resource 
Availability. 

2. Create a full 1-, 5-, or 7-day schedule for a particular resource using Access 
Blocks as described in Setting up Clinic Availability. 

3. Click Save Template on the File menu. The Save As window displays. 
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Figure 71: Save As window 

4. Type file name of the template in the File Name field. Use a descriptive template 
name to allow for multiple templates that are easy to identify by name, such as 
pedtemplate.bsdxa or 15mintemplate.bsdxa. 

5. Select a location for templates using the Save In drop-down list. A user may want 
to create a separate folder to store templates, such as BSDX Templates. 

6. Click Save to save a template. 

6.1.5.2 Applying a Scheduling Template Check 
This section provides instructions for setting up a schedule for a resource using a 
Scheduling Template. 

To apply a scheduling template: 

1. Open the Edit Availability window by right-clicking a resource and choosing 
Edit Resource Availability. 

2. Select a 1- Day View, 5- Day View, or 7-Day View from the View menu. 

3. Click Apply Template on the File menu. 

The Apply Access Template window displays. 
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Figure 72: Apply Access Template window 

4. Click Select Access Template. The Open dialog box is displayed. 

5. Locate the folder that contains templates and choose a template. 

Note: A template has a .bsdxa file extension. 

6. Click Open to apply the template or Cancel to cancel your action. 

7. Choose the desired week to create a schedule by selecting a week from the 
Starting Week (Monday) list. 

8. Choose the number of weeks to create schedules from the Number of Weeks to 
Apply list. 

9. Click OK to apply this template to the schedule or Cancel to return to the Edit 
Availability window without creating a new schedule. 

Note: A user cannot load a template if there are Access Blocks 
defined for that particular week. 

Individual Access Blocks can be edited using the Edit Access Block feature. 
Refer to Editing an Access Block for more information. 
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6.2 Using the Scheduling Management Window 
This section provides instructions for setup and administration tasks using the 
Scheduling Management window. Using this window, the Clinical Scheduling 
administrator can set up users and their privileges as well as schedules for the 
availability of doctors, procedures, clinics and the layout and appearance of the 
overall schedule. A resource has to be linked to an RPMS scheduling clinic so that 
when a patient has an appointment at that clinic and checks in, a PCC visit will be 
created for that clinic. 

The procedures described in this section require the manager key. See your site 
administrator to determine or change your security keys. The Scheduling 
Management window displays the options: 

With the exception of the Copy Appointments tab, each tab contains a table. You 
can expand the first column of the table by clicking the Maximize icon (+). These 
rows are called group list rows. 

 
Figure 73: Scheduling Management window 
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By clicking the Maximize icon (+), the sublist is displayed in blue. Click the sublist to 
view the options for that list. When selecting a sublist, a user can return to the group 
list by clicking the left-arrow button located in the top right side of the table view. 
You can also click the Show/Hide button for the current set of sub lists. 

 
Figure 74: Show/Hide button 

6.2.1 Defining Resources and Users 
The Resources and Users tab enables the user to define the set of resources available 
for scheduling at your facility. Resources can include providers (such as Dentists and 
Physicians) or other kinds of scheduled services, facilities, or equipment. The 
Resource User list, shown below, enables you to manage the users who can schedule 
the resource. To define the parameters of an RPMS Resource, you must log on to 
RPMS and use the PIMS Scheduling Supervisor’s menus. 

 
Figure 75: Resources and Users tab in Scheduling Management window 

6.2.1.1 Adding a Resource 
To add a new Resource: 

1. Select Scheduling Management from the File menu. 
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2. Click the Resources and Users tab in the Scheduling Management window. 

3. Click Add. The Add New Scheduling Resource window appears. 

 
Figure 76: Add New Scheduling Resource window 

4. Type the name of the resource in the Resource Name field. 

5. Select the default time scale for appointments from the Time Scale drop-down 
list. This time interval controls the time interval between appointments. 

6. Select the clinic, as needed, that you want this resource linked to from the RPMS 
Clinic drop-down list in the RPMS Clinic field. 

7. Select Reminder Letter, Rebook Letter, or Cancellation Letter and modify the 
text as necessary. The figure below provides an example of letter text. 

Important: Do not press Enter at the end of a line. Doing so 
closes this window, sends an error message, and returns 
you to the previous window. 
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Figure 77: Add New Scheduling Resource window 

8. Click OK to save a letter or Cancel to dismiss the window without saving entries. 

6.2.1.2 Editing a Resource 
Using the instructions in this section, you can complete the following: 

• Edit a resource name. 

• Inactivate or reactivate a resource. 

• Change the time scale of a resource. 

• Revise RPMS clinic link information. 

• Edit patient letters using the Reminder, Reboot, and Cancellation Letter tabs. 

To edit a Resource: 

1. Select Scheduling Management from the File menu. 

2. Click the Resources and Users tab in the Edit Scheduling Resource window 
shown below. 
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Figure 78: Edit Scheduling Resource window 

3. Select the resource to edit. 

4. Click Change. The Edit Scheduling Resource window appears. 

 
Figure 79. Edit Scheduling Resource Window 

5. Make the following changes as necessary: 

• Change the name of the resource in the Resource Name field. 

• Select or deselect the Inactive box to inactive or reactive this resource. 

• Reset the minutes by selecting another number from the Time Scale list. 
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• Edit the fields in the RPMS Clinic Link tab. To define the parameters for an 
RPMS clinic, log on to RPMS and use the RPMS Scheduling Supervisor’s 
menu. 

• Select Reminder Letter, Rebook Letter, or Cancellation Letter and edit the 
text as necessary. The following is an example of letter text. 

 
Figure 80: Reminder Letter tab  

Note: Do not press Enter at the end of a line. Doing so closes this 
window, sends an error message, and returns you to the 
previous window. 

6. Click OK to save changes, or Cancel to dismiss the window without saving 
entries. 

6.2.1.3 Maintaining Resource Users 
Use these steps to add, change, or remove users who can create appointments and 
establish availability for this resource. Users must first be given basic access to the 
RPMS Scheduling component, using standard RPMS menu and key allocation before 
they can be selected and assigned as a resource user. 

To add, change, or remove Resource users. 
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1. Select Scheduling Management from the File menu. 

2. Click the Resources and Users tab in the Scheduling Management window. 

3. Expand the resource by clicking the Maximize icon (+) next to it. 

 
Figure 81: Defining Resource Users 

4. Click ResourceUser. The current list of Resource Users is displayed.  
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Figure 82: New Resource User added 

5. Do one of the following: 

• Click Add User to add a new user. The Add New Resource User window 
displays. Type the name of the new user and check the boxes as necessary. To 
allow a user to be able to overbook appointments, select the Overbook check 
box. To allow a user to modify the schedule, select the Modify Clinic 
Availability check box. Click OK to add this user or Cancel to dismiss the 
window without saving entries. 

Note: At least one user at a site must be able to perform each of 
the tasks listed. It is also recommended that a limited 
number of users at each site have Modify Clinic 
Availability privileges. 

• Select a user and click Change User to edit an existing user. The Edit 
Scheduling Resource window displays. Select the attributes for the selected 
user as necessary. To allow a user to overbook appointments, click the 
Overbook drop-down menu and select the applicable authority level (None, 
Regular, or Master. Click OK to save changes, or Cancel to discard the 
changes. 

Note: Only users who have the BSDXZMENU key in RPMS 
appear in the selection list. When editing an existing user, 
name changes are not permitted. 
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Figure 83: Edit Scheduling Resource window 

• Select a user and click Remove User. Figure 84: Scheduling Management 
window with Resources and Users tab selected shows the updated window 
after a user was deleted from this resource. There is no confirmation message 
before the user is deleted so be careful to select the correct user. Click OK to 
save changes or Cancel to discard the window and keep this user. 

 
Figure 84: Scheduling Management window with Resources and Users tab selected 

6.2.2 Resource Groups 
Use this window to organize resources into useful groups. Resource Groups may 
include departments, clinics, or any other collection of resources. Resource Groups 
are visible to all scheduling users. 

To display the Scheduling Management window, select Scheduling Management 
from the File menu. 
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Figure 85: Scheduling Management window with Resource Groups tab 

6.2.2.1 Adding a Resource Group 
This section provides instructions for adding a resource group. In the example below, 
there are two resource groups displayed. After adding a resource group, a user can 
add resources to the resource groups that have been created. Refer to Adding 
Resources to Resource Groups for instructions. 

To add a Resource Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

3. Click Add Group to add a new Resource Group. The Add New Resource Group 
window is displayed. 

4. Type the name of the new Resource Group in the Resource Group Name field as 
shown below. 
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Figure 86: Adding a Resource Group 

5. Click OK to add the new Resource Group to the list of Resource Groups as 
shown in Figure 87: Adding a Resource Group, or Cancel to dismiss the window 
without adding the entry. 

 
Figure 87: Adding a Resource Group 

If desired, add resources to the resource groups you created. Refer to Adding 
Resources to Resource Groups for instructions. Otherwise, select another tab or click 
Close to exit the Scheduling Management window. 

6.2.2.2 Adding Resources to Resource Groups 
This section provides instructions for adding resources such as diagnostics, clinics, 
procedures, and so on to a resource. 
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To add a resource to a resource group: 

1. Select Scheduling Management from the File menu. 

2. Click Resource Groups tab in the Scheduling Management window. 

3. Click the Maximize icon (+) next to the Resource Group to add a resource as 
shown below. 

 
Figure 88: Adding resources to groups 

4. Click GroupResource. A list of available resources is displayed as shown below. 

 
Figure 89: Adding resources to groups 
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Select the resource to add from the Select Resource drop-down list in the Add New 
Resource to Group window and click OK. Otherwise, select another tab or click 
Close to exit the Scheduling Management window. 

The Resource is now listed in the Resource Group as shown below. 

 
Figure 90: Scheduling Management window with new resource group 

To remove a resource, refer to Removing a Resource from Resource Groups. 

6.2.2.3 Removing a Resource from Resource Groups 
To remove a Resource from a Resource group: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window.  
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Figure 91: Adding a Resource Group 

3. Click the Maximize icon (+) next to the Resource Group to remove a resource. 

 
Figure 92: Opening a list of resources 

4. Click GroupResource to display a list of resources similar to the one shown 
below. 
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Figure 93: Removing a resource 

5. Select the resource to remove from the list. 

6. Click Remove Resource to delete this resource from the list. There is no 
confirmation message before the resource is deleted so be careful to select the 
correct resource. This does not delete the resource completely; it only removes the 
resource from the Resource Group. 

7. To remove more resources, repeat this procedure. Otherwise, select another tab or 
click Close to exit the Scheduling Management window. 

6.2.2.4 Editing a Resource Group 
This section provides instructions for editing a Resource group. 

To edit a Resource Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

3. Select the Resource Group to change. 

4. Click Change Group to edit this Resource Group. The Edit Resource Group 
window appears. 



Clinical Scheduling for Windows (BSDX) Version 3.0 

User Guide Setting Up and Administering BSDX 
April 2011 

83 

 
Figure 94: Edit Resource Group window 

5. Change the name of the Resource Group in the Resource Group Name text box. 
No changes are made to the actual resources within the Resource Groups. 

6. Click OK to save changes or Cancel to dismiss the Edit Resource Group and 
return to the Resource Groups tab without changing the name. 

7. Repeat this procedure to edit more Resource Groups, select another tab, or click 
Close to exit the Scheduling Management window. 

6.2.2.5 Removing a Resource Group 
Use this option to remove Resource Groups that are no longer needed. This does not 
delete the resources within the group; only the group is deleted. 

To remove a Resource Group, follow: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

3. Select the Resource Group to remove as shown below. 
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Figure 95: Removing a Resource Group 

4. Click Remove Group to remove a Resource Group. 

Note:  There is no prompt asking to confirm a choice, so be 
careful when removing Resource Groups. 

5. Repeat this procedure to remove more Resource Groups; select another tab, or 
click Close to exit the Scheduling Management window. 

6.2.3 Access Types 
Access types refer to the type of appointment being scheduled, such as routine 
physical, injection, and so on. The following procedures provide instructions for 
adding and editing Access Types that are used when scheduling an appointment. 

6.2.3.1 Add an Access Type 
The following procedure provides instructions for adding an access type. An access 
type describes an appointment category (for example: walk-in, first visit, routine 
exam, consultation, and so on. 

To add an Access Type: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Types tab in the Scheduling Management window. 
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3. Click Add Access Type to add a new Access Type. The Manage Access Types 
window is displayed. 

4. Type the name of the new Access Type in the Access Type Name field of the 
Manage Access Types window. 

5. Click Select Display Color. The Color window displays. 

 

Figure 96: Manage Access Types 

6. Click a color swatch for the Basic color to be assigned to the new access type or 
click Define Custom Colors to create a new color. 

Note: Click Add Custom Colors to save it on Custom colors 
palette. 

7. Click OK on the Colors window. 

8. Click OK on the Manage Access Types window. 

9. Click OK in the Manage Access Types window. The new Access Type is now 
listed on the Access Types list. 

10. Repeat this procedure to add more Access Types, select another tab, or click 
Close to exit the Scheduling Management window. 
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6.2.3.2 Edit an Access Type 
This section provides instructions for editing an access type. Using the instructions in 
this section a user can: 

• Edit an access type name 

• Change the color used to display an access type 

• Change the status of an access type (by checking or unchecking Inactive) 

To edit an Access Type: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Types tab in the Scheduling Management window. 

3. Select the row for the Access Type to edit. Same Day is selected on the Access 
Types tab. 

 
Figure 97: Screen examples for editing an Access Type 

4. Click Change Access Type to edit the Access Type. The Manage Access Types 
window shown above displays. 

5. Do any of the following as necessary: 

• Change the Access Type name. 

• Click another color swatch for the Basic color to assign to the access type or 
click Define Custom Colors to create a new color. 

• Click Add Custom Colors to save it on Custom colors palette. 
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• Select or deselect the Inactive check box to change the status of the Access 
Type. 

– Click OK to save changes or Cancel to dismiss the Manage Access 
Types and return to the Access Types tab without saving changes. 

– Repeat this procedure to edit more Access Types, select another tab, or 
click Close to exit the Scheduling Management window. 

6.2.4 Access Groups 
Access Groups are categories of different Access Types. Access Types can be 
organized for faster searching and scheduling. 

6.2.4.1 Add an Access Group 
The following procedure provides instructions for adding an Access Group. 

To add an Access Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window to display 
the Add New Access Group window. 

 

Figure 98: Add New Access Group window 

3. Click Add Group to add a new Access Group. The Add New Access Group 
window shown above displays. 

4. Type the name of the new Access Group in the Access Group Name field. 

5. Click OK to add the new Access Group or Cancel to close the Add New Access 
Group window. 
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If OK was clicked, the new Access Group is listed in the window as shown 
below. 

  
Figure 99: Access Group list with a new Access Group added 

Repeat this procedure to add more Access Groups, select another tab, or click Close 
to exit the Scheduling Management window. To add Access Types to Access 
Groups, refer to Adding Access Types to Access Groups in the next section. 

6.2.4.2 Adding Access Types to Access Groups 
To add an Access Type to Access Groups 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window. 

3. Click the Maximize icon (+) next to the appropriate Access Group, as shown 
below. 
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Figure 100: Adding an AccessGroup Type 

4. Click AccessGroupType. The list shown below displays. 

 
Figure 101: Adding an Access Type 

5. Click Add Type. The Add New Access Type to Group window shown below 
displays. 
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Figure 102: Adding a New Access Type 

6. Select an Access Type from the Select Access Type drop-down list and click OK 
to add this Access Type or Cancel to return to the Scheduling Management 
Window without adding this Access Type. 

If OK was clicked, the new Access Type is now listed.  

 
Figure 103: New Access Type added to Access Group 
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7. Continue adding more Access Types by using this procedure. Select another tab, 
or click Close to exit the Scheduling Management window. 

6.2.4.3 Edit an Access Group 
To edit an Access Group 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window. 

3. Select the appropriate Access Group. 

4. Click Change. The Edit Access Group window displays. 

 
Figure 104: Editing an Access Group 

5. Edit the name of the Access Group in the Access Group Name field shown. No 
changes are made to the actual Access Types within the Access Groups. 

6. Click OK to save the edited Access Group name or Cancel to return to the 
Scheduling Management window without changing the name. 

7. Continue editing Access Group names by repeating this procedure. Or, select 
another tab, or click Close to exit the Scheduling Management window. 

6.2.4.4 Remove an Access Group 
The procedure that follows provides instructions for removing an Access Group that 
is no longer needed. This does not delete the Access Types within the group; only the 
Access Group is deleted. 
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To remove an Access Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window. 

3. Select the Access Group to be removed. 

4. Click Remove Group to remove an Access Group as shown below. 

 
Figure 105: Removing an Access Group 

The Access Group is removed from the Access Groups window. 

Note: There is no prompt asking to confirm a choice, so be 
careful when removing Access Groups. 

5. Continue updating Access Groups. Or, select another tab, or click Close to exit 
the Scheduling Management window. 

6.2.5 Copy Appointments 
The following procedure provides instructions for copying appointments from an 
RPMS clinic into this application. Copying appointments from RPMS eliminates the 
need to manually enter an appointment into the GUI Scheduling application. All 
appointments, except cancelled appointments, may be copied. 

To copy appointments from RPMS to an MS Windows Scheduling Resource, 

1. Select Scheduling Management from the File menu. 
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2. Click the Copy Appointments tab in the Scheduling Management window to 
open the Copy Appointments tab shown below. 

 
Figure 106: Copying Appointments from RPMS into Windows Scheduling Resource 

3. Select the RPMS clinic to copy appointments using the Copy From RPMS 
Clinic drop-down menu. 

4. Select the Scheduling Resource to copy the appointments using the Copy To 
Windows Scheduling Resource drop-down menu. 

5. Select the beginning date for the appointment transfer from the Start with 
appointments on drop-down menu. 

6. Select the ending date for the appointment transfer from the End with 
appointments on drop-down menu. 

7. Click Copy Appointments. The Copy Appointments window opens displaying 
Job Summary and Status boxes. 
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Figure 107: Copying appointments from RPMS into Windows Scheduling Resource 

8. Click Cancel to stop the transfer before it finishes or click OK when the transfer 
is done. 

9. Continue copying more RPMS clinic schedules to this application. A user can 
also select another tab, or click Close to exit the Scheduling Management 
window. 

6.2.6 WorkStations 
The WorkStations tab in Schedule Management allows a system administrator to 
view, communicate with, and shut down workstations running the clinical scheduling 
application. 

6.2.6.1 Refresh Workstations List 
To view the current list of workstations at a site running clinical scheduling 
software: 

1. Select Scheduling Management from the File menu. 

2. Click the WorkStations tab in the Scheduling Management window to display 
the window shown below. 
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Figure 108: Workstations tab 

3. Click Refresh to display a list of the workstations at a site running the clinical 
scheduling application.  

 
Figure 109: Refresh list of Active Workstations 

4. Another task may be selected by choosing another tab, or click Close to exit the 
Scheduling Management window. 
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6.2.6.2 Send Message to Workstations 
This section provides instructions for sending messages to workstations on a network 
currently running this application. This is useful when it is necessary to shut down the 
network or to communicate with all users logged on to the application. 

To send a message to workstations currently logged on to this application: 

1. Select Scheduling Management from the File menu. 

2. Click the WorkStations tab in the Scheduling Management window. 

3. Click Refresh. A list showing the workstations at a site currently running clinical 
scheduling application is updated. 

4. Click Send Message. The Send Message to Scheduling Client window opens. 

 

Figure 110: Send Message to Scheduling Clients window 

Type the message in the text field and click OK. The message is sent to all users 
currently logged on to this application. Figure 111: Sent Message is an example of a 
message users will receive. The sender will not receive the message nor any 
confirmation it was sent. 
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Figure 111: Sent Message 

5. Another Scheduling Management tab may be selected, or click Close to exit 
Scheduling Management. 

6.2.6.3 Stop Workstations 
To stop all workstations currently running this application: 

1. Select Scheduling Management from the File menu. 

2. Click the WorkStations tab in the Scheduling Management window. 

3. Click Refresh. A list of the workstations running clinical scheduling software is 
displayed.  

 
Figure 112: Stop Workstations 

4. Type a brief notification message in the field shown above, and click Stop 
Workstations. The IHS Clinical Scheduling Client Shutdown confirmation 
dialog box displays. 
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Figure 113: Shutdown Confirmation dialog box 

5. Click Yes to confirm shutdown or No to return to the Workstation tab. 

The message is sent to all users currently logged on to this application. Figure 
110: Send Message to Scheduling Clients , is provided as an example of a 
message users receive. The sender will not receive the message nor any 
confirmation it was sent. 

 
Figure 114: Shutdown notification message 

Important: Users must click OK before the system can 
shutdown. All information entered into the system prior to 
the shutdown is saved. 

6. To verify that all systems have been shutdown, perform a Refresh to locate all 
users still running the clinical scheduling software. The system administrator 
should be the only one on the list. 

7. Click Close to exit Scheduling Management and the shutdown commences. 
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7.0 Rules of Behavior Overview 

7.1 Background 
The IHS Information Technology (IT) Rules of Behavior (RoB) summarize the laws 
and guidance from various IHS, Department of Health and Human Services (HHS), 
and other federal requirements. All users of IHS IT resources should be fully aware 
of, and abide by, IHS security policies as well as related federal policy contained in 
the Office of Management and Budget (OMB) Circular A-130, the Health Insurance 
Portability and Accountability Act (HIPAA), the Privacy Act, the Freedom of 
Information Act (FOIA), and IHS Records Management Policy and procedures. 
These guidelines should be used by all IHS organizational components as a basis for 
their own security plans and procedures. 

These RoBs are founded on the principles described in the IHS published security 
policies and other regulatory documents such as the Code of Ethics for Government 
Employees, Office of Personnel Management regulations, OMB regulations and 
Standard of Conduct for Federal Employees, HHS policy and procedure and NIST 
Special Publications. Therefore, these RoBs carry the same responsibility for 
compliance as the official documents. 

7.2 Purpose 
The purpose of this Statement of Procedure (SOP) is to establish the RPMS RoBs. 
The RPMS RoBs are part of a comprehensive program to provide complete 
information security. These guidelines were established to hold users accountable for 
their actions and responsible for information security. The RPMS RoBs establish 
standards of behavior in recognition of the fact that knowledgeable users are the 
foundation of a successful security program. Users need to understand that taking 
personal responsibility for the security of their computer and the data it contains is an 
essential part of their job. 

IHS has many computer systems to which IHS, Tribal, or Urban (I/T/U) employees 
must be given access in order to accomplish their jobs. As each user processes into an 
organization upon initial employment, changes jobs within the organization, or leaves 
the organization, there is an opportunity and responsibility for the organization to 
give or take away access to IT systems. It is at these junctions in the employment 
process that the rules pertaining to this access should be explained to and agreed upon 
by the employer and the employee. It is the responsibility of the users, supervisors, 
and computer systems administrators to follow the policies, regulations, and 
procedures to protect and assure that IT resources are appropriately protected when 
authorizing access of IHS automated information and systems. 
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7.3 Scope 
This SOP applies to all IHS organizational components including, but not limited to, 
IHS headquarters offices and functions; all IHS area office locations and functional 
areas; all IHS service units and functions; all IHS funded or direct supported health 
facilities or locations. Also included are all IHS partners’ facilities as described 
below. The term facilities includes all Indian Health Urban locations where health 
care is provided or managed; and all IHS or Tribally owned or operated hospitals, 
clinics, or all other locations where the health care services are provided, managed or 
otherwise supported. 

• Facilities managed by Tribes or Tribal organizations that have retained IT shares 
with the IHS shall follow this SOP in accordance with their contracts or compacts. 

• It is recommended that facilities managed by Tribes or Tribal organizations that 
have taken their Information Technology shares follow this SOP. 

• Contractors’ facilities shall follow this SOP in accordance with their 
interconnection agreements with IHS. 

• For the purposes of this document, the use of the term IHS is intended to include 
any of the above facilities and employees of same. 

• These RoB procedures apply to all IHS facilities and are in accordance with HHS 
reporting requirements and directives. 

• This also includes individuals conducting business on behalf of the IHS through 
contractual relationships, unless they are specifically excluded under the terms of 
their contract. 

The policies contained in this SOP apply to all RPMS IT activities including the 
equipment, procedures, and technologies that are employed in managing these 
activities. The policy includes work performed while teleworking or traveling, at 
other off-site locations, and at all IHS office locations. 
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8.0 Specific RPMS Rules of Behavior 
The Resource and Patient Management (RPMS) system is a United States 
Department of Health and Human Services (HHS), Indian Health Service (IHS) 
information system that is FOR OFFICIAL USE ONLY. The RPMS system is 
subject to monitoring; therefore, no expectation of privacy shall be assumed. 
Individuals found performing unauthorized activities are subject to disciplinary action 
including criminal prosecution. 

All users (Contractors and IHS Employees) of RPMS will be provided a copy of the 
Rules of Behavior (RoB) and must acknowledge that they have received and read 
them prior to being granted access to a RPMS system, in accordance IHS policy. 

• For a listing of general ROB for all users, see the most recent edition of IHS 
General User Security Handbook (SOP 06-11a).  

• For a listing of system administrators/managers rules, see the most recent edition 
of the IHS Technical and Managerial Handbook (SOP 06-11b). 

Both documents are available at this IHS Web site: http://security.ihs.gov/. 

The ROB listed in the following sections are specific to RPMS.  

8.1 All RPMS Users 
In addition to these rules, each application may include additional RoBs that may be 
defined within the documentation of that application (e.g., Dental, Pharmacy). 

8.1.1 Access 
RPMS users shall 

• Only use data for which you have been granted authorization. 

• Only give information to personnel who have access authority and have a need to 
know.  

• Always verify a caller’s identification and job purpose with your supervisor or the 
entity provided as employer before providing any type of information system 
access, sensitive information, or nonpublic agency information. 

• Be aware that personal use of information resources is authorized on a limited 
basis within the provisions Indian Health Manual Part 8, “Information Resources 
Management,” Chapter 6, “Limited Personal Use of Information Technology 
Resources.” 

RPMS users shall not 

• Retrieve information for someone who does not have authority to access the 
information. 

http://security.ihs.gov/�


Clinical Scheduling for Windows (BSDX) Version 3.0 

User Guide Specific RPMS Rules of Behavior 
April 2011 

102 

• Access, research, or change any user account, file, directory, table, or record not 
required to perform their official duties. 

• Store sensitive files on a PC hard drive, or portable devices or media, if access to 
the PC or files cannot be physically or technically limited. 

• Exceed their authorized access limits in RPMS by changing information or 
searching databases beyond the responsibilities of their jobs or by divulging 
information to anyone not authorized to know that information. 

8.1.2 Information Accessibility 
RPMS shall restrict access to information based on the type and identity of the user. 
However, regardless of the type of user, access shall be restricted to the minimum 
level necessary to perform the job. 

RPMS users shall 

• Access only those documents they created and those other documents to which 
they have a valid need-to-know and to which they have specifically granted 
access through an RPMS application based on their menus (job roles), keys, and 
FileMan access codes. Some users may be afforded additional privileges based on 
the functions they perform, such as system administrator or application 
administrator. 

• Acquire a written preauthorization in accordance with IHS policies and 
procedures prior to interconnection to or transferring data from RPMS. 

8.1.3 Accountability 
RPMS users shall 

• Behave in an ethical, technically proficient, informed, and trustworthy manner. 

• Log out of the system whenever they leave the vicinity of their personal 
computers (PCs). 

• Be alert to threats and vulnerabilities in the security of the system. 

• Report all security incidents to their local Information System Security Officer 
(ISSO)  

• Differentiate tasks and functions to ensure that no one person has sole access to or 
control over important resources. 

• Protect all sensitive data entrusted to them as part of their government 
employment. 

• Abide by all Department and Agency policies and procedures and guidelines 
related to ethics, conduct, behavior, and information technology (IT) information 
processes. 
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8.1.4 Confidentiality 
RPMS users shall 

• Be aware of the sensitivity of electronic and hard copy information, and protect it 
accordingly. 

• Store hard copy reports/storage media containing confidential information in a 
locked room or cabinet. 

• Erase sensitive data on storage media prior to reusing or disposing of the media. 

• Protect all RPMS terminals from public viewing at all times. 

• Abide by all Health Insurance Portability and Accountability Act (HIPAA) 
regulations to ensure patient confidentiality. 

RPMS users shall not 

• Allow confidential information to remain on the PC screen when someone who is 
not authorized to that data is in the vicinity. 

• Store sensitive files on a portable device or media without encrypting. 

8.1.5 Integrity 
RPMS users shall 

• Protect their systems against viruses and similar malicious programs. 

• Observe all software license agreements.  

• Follow industry standard procedures for maintaining and managing RPMS 
hardware, operating system software, application software, and/or database 
software and database tables. 

• Comply with all copyright regulations and license agreements associated with 
RPMS software. 

RPMS users shall not 

• Violate federal copyright laws. 

• Install or use unauthorized software within the system libraries or folders. 

• Use freeware, shareware, or public domain software on/with the system without 
their manager’s written permission and without scanning it for viruses first. 

8.1.6 System Logon 
RPMS users shall 

• Have a unique User Identification/Account name and password. 
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• Be granted access based on authenticating the account name and password 
entered. 

• Be locked out of an account after five successive failed login attempts within a 
specified time period (e.g., one hour). 

8.1.7 Passwords 
RPMS users shall 

• Change passwords a minimum of every 90 days. 

• Create passwords with a minimum of eight characters. 

• If the system allows, use a combination of alpha-numeric characters for 
passwords, with at least one uppercase letter, one lower case letter, and one 
number. It is recommended, if possible, that a special character also be used in the 
password. 

• Change vendor-supplied passwords immediately. 

• Protect passwords by committing them to memory or store them in a safe place 
(do not store passwords in login scripts or batch files).  

• Change passwords immediately if password has been seen, guessed, or otherwise 
compromised, and report the compromise or suspected compromise to their ISSO. 

• Keep user identifications (IDs) and passwords confidential. 

RPMS users shall not 

• Use common words found in any dictionary as a password. 

• Use obvious readable passwords or passwords that incorporate personal data 
elements (e.g., user’s name, date of birth, address, telephone number, or social 
security number; names of children or spouses; favorite band, sports team, or 
automobile; or other personal attributes). 

• Share passwords/IDs with anyone or accept the use of another’s password/ID, 
even if offered. 

• Reuse passwords. A new password must contain no more than five characters per 
eight characters from the previous password. 

• Post passwords. 

• Keep a password list in an obvious place, such as under keyboards, in desk 
drawers, or in any other location where it might be disclosed. 

• Give a password out over the phone. 
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8.1.8 Backups 
RPMS users shall 

• Plan for contingencies such as physical disasters, loss of processing, and 
disclosure of information by preparing alternate work strategies and system 
recovery mechanisms. 

• Make backups of systems and files on a regular, defined basis.  

• If possible, store backups away from the system in a secure environment. 

8.1.9 Reporting 
RPMS users shall 

• Contact and inform their ISSO that they have identified an IT security incident 
and begin the reporting process by providing an IT Incident Reporting Form 
regarding this incident. 

• Report security incidents as detailed in the IHS Incident Handling Guide (SOP 
05-03). 

RPMS users shall not 

• Assume that someone else has already reported an incident. The risk of an 
incident going unreported far outweighs the possibility that an incident gets 
reported more than once. 

8.1.10 Session Timeouts 
RPMS system implements system-based timeouts that back users out of a prompt 
after no more than 5 minutes of inactivity. 

RPMS users shall 

• Utilize a screen saver with password protection set to suspend operations at no 
greater than 10 minutes of inactivity. This will prevent inappropriate access and 
viewing of any material displayed on the screen after some period of inactivity. 

8.1.11 Hardware 
RPMS users shall 

• Avoid placing system equipment near obvious environmental hazards (e.g., water 
pipes).  

• Keep an inventory of all system equipment.  

• Keep records of maintenance/repairs performed on system equipment. 
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RPMS users shall not 

• Eat or drink near system equipment. 

8.1.12 Awareness 
RPMS users shall 

• Participate in organization-wide security training as required.  

• Read and adhere to security information pertaining to system hardware and 
software. 

• Take the annual information security awareness. 

• Read all applicable RPMS manuals for the applications used in their jobs. 

8.1.13 Remote Access 
Each subscriber organization establishes its own policies for determining which 
employees may work at home or in other remote workplace locations. Any remote 
work arrangement should include policies that 

• Are in writing. 

• Provide authentication of the remote user through the use of ID and password or 
other acceptable technical means. 

• Outline the work requirements and the security safeguards and procedures the 
employee is expected to follow. 

• Ensure adequate storage of files, removal, and nonrecovery of temporary files 
created in processing sensitive data, virus protection, and intrusion detection, and 
provide physical security for government equipment and sensitive data. 

• Establish mechanisms to back up data created and/or stored at alternate work 
locations. 

Remote RPMS users shall 

• Remotely access RPMS through a virtual private network (VPN) whenever 
possible. Use of direct dial in access must be justified and approved in writing and 
its use secured in accordance with industry best practices or government 
procedures. 

Remote RPMS users shall not 

• Disable any encryption established for network, internet, and Web browser 
communications. 
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8.2 RPMS Developers 
RPMS developers shall 

• Always be mindful of protecting the confidentiality, availability, and integrity of 
RPMS when writing or revising code. 

• Always follow the IHS RPMS Programming Standards and Conventions (SAC) 
when developing for RPMS. 

• Only access information or code within the namespaces for which they have been 
assigned as part of their duties. 

• Remember that all RPMS code is the property of the U.S. Government, not the 
developer. 

• Not access live production systems without obtaining appropriate written access, 
and shall only retain that access for the shortest period possible to accomplish the 
task that requires the access. 

• Observe separation of duties policies and procedures to the fullest extent possible. 

• Document or comment all changes to any RPMS software at the time the change 
or update is made. Documentation shall include the programmer’s initials, date of 
change, and reason for the change. 

• Use checksums or other integrity mechanism when releasing their certified 
applications to assure the integrity of the routines within their RPMS applications. 

• Follow industry best standards for systems they are assigned to develop or 
maintain, and abide by all Department and Agency policies and procedures. 

• Document and implement security processes whenever available. 
RPMS developers shall not 

• Write any code that adversely impacts RPMS, such as backdoor access, “Easter 
eggs,” time bombs, or any other malicious code or make inappropriate comments 
within the code, manuals, or help frames. 

• Grant any user or system administrator access to RPMS unless proper 
documentation is provided.  

• Release any sensitive agency or patient information. 
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8.3 Privileged Users 
Personnel who have significant access to processes and data in RPMS, such as, 
system security administrators, systems administrators, and database administrators, 
have added responsibilities to ensure the secure operation of RPMS. 

Privileged RPMS users shall 

• Verify that any user requesting access to any RPMS system has completed the 
appropriate access request forms. 

• Ensure that government personnel and contractor personnel understand and 
comply with license requirements. End users, supervisors, and functional 
managers are ultimately responsible for this compliance. 

• Advise the system owner on matters concerning information technology security. 

• Assist the system owner in developing security plans, risk assessments, and 
supporting documentation for the certification and accreditation process. 

• Ensure that any changes to RPMS that affect contingency and disaster recovery 
plans are conveyed to the person responsible for maintaining continuity of 
operations plans.  

• Ensure that adequate physical and administrative safeguards are operational 
within their areas of responsibility and that access to information and data is 
restricted to authorized personnel on a need-to-know basis.  

• Verify that users have received appropriate security training before allowing 
access to RPMS. 

• Implement applicable security access procedures and mechanisms, incorporate 
appropriate levels of system auditing, and review audit logs.  

• Document and investigate known or suspected security incidents or violations and 
report them to the ISSO, Chief Information Security Officer (CISO), and systems 
owner. 

• Protect the supervisor, superuser, or system administrator passwords. 

• Avoid instances where the same individual has responsibility for several functions 
(i.e., transaction entry and transaction approval). 

• Watch for unscheduled, unusual, and unauthorized programs. 

• Help train system users on the appropriate use and security of the system. 

• Establish protective controls to ensure the accountability, integrity, 
confidentiality, and availability of the system. 

• Replace passwords when a compromise is suspected. Delete user accounts as 
quickly as possible from the time that the user is no longer authorized system. 
Passwords forgotten by their owner should be replaced, not reissued. 
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• Terminate user accounts when a user transfers or has been terminated. If the user 
has authority to grant authorizations to others, review these other authorizations. 
Retrieve any devices used to gain access to the system or equipment. Cancel 
logon IDs and passwords, and delete or reassign related active and backup files. 

• Use a suspend program to prevent an unauthorized user from logging on with the 
current user's ID if the system is left on and unattended. 

• Verify the identity of the user when resetting passwords. This can be done either 
in person or having the user answer a question that can be compared to one in the 
administrator’s database. 

• Shall follow industry best standards for systems they are assigned to, and abide by 
all Department and Agency policies and procedures. 

Privileged RPMS users shall not 

• Access any files, records, systems, etc., that are not explicitly needed to perform 
their duties. 

• Grant any user or system administrator access to RPMS unless proper 
documentation is provided.  

• Release any sensitive agency or patient information. 
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9.0 Specific BSDX RoBs 
There are no specific RoBs that are applicable to BSDX.
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Glossary 

Access Block 
Access Blocks are color-coded representations of the amount of time allotted 
for a specific Access Type (or appointment). 

Access Type 
Access Types refer to the variety of different appointment types available in 
the RPMS. Each type of appointment, such as routine physical, dental, walk-
in, or other specific appointment type is an Access Type. 

Access Group 
Access Groups are categories of Access Types. Assigning Access Types to 
Access Groups makes it easier to schedule and search for certain types of 
appointments. 

Appointment Date Selector 
Appears in the upper right corner of the screen, below the Minimize, 
Maximize, and Exit buttons. The date selected is the starting date of the 
appointments currently displayed in the scheduled pane. The range of 
appointments displayed can be 1-day, 5-day, or 7-day. 

Archiving  
The storing of historical or little-used data off-line (often on tape). 

ASUFAC Number 
A unique identifier for each facility within IHS. A six-digit number comprised 
of 2 digits for Area, 2 digits for Service Unit, and 2 digits for Facility. 

Client Window 
Area on a screen that shows the work space for an application. 

Default Facility 
A user selects a facility identification to work with patients registered to that 
facility. 

Health Record Number (HRN) 
Each facility assigns a unique number within that facility to each patient. Each 
HRN with its facility identification ASUFAC make a unique identifier within 
all of IHS. 

Internal Entry Number (IEN) 
The number used to identify an entry within a file. Every record has a unique 
internal entry number. 
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Information Resource Management (IRM) 
The IHS personnel responsible for information systems management and 
security. 

Menu 
An item on the menu bar of an MS Windows application that includes a list of 
commands for performing specific actions. For example, the File menu 
includes commands for opening, saving, and printing files.  

Menu Bar 
Appears below the Name and location of the current user. The available text 
menus are: File, Appointment, View, and Help. 

Namespace 
A unique set of 2 to 4 alpha characters that are assigned by the database 
administrator to a software application. 

Official Registering Facility 
A facility designated so when HRNs are added/modified, those changes are 
sent to the central database. A Service Unit may have several satellites for 
which it is registering patients. 

Pane 
A rectangular division of a screen window that contains information for the 
user. A window may have many panes. 

Patient Care Component (PCC) 
The central repository for data in the RPMS. 

Resource 
The term resource refers to any person, service, or clinic for which a patient 
can be scheduled. Resources can be physicians, diagnostic equipment such as 
MRI, CT scan, ultrasound, and so on, or specialty appointment slots, such as 
physical therapy. However, only resources that are clinics can be linked to an 
RPMS PIMS schedule. 

Resource Group 
Resource Groups are categories of resources that help to organize the variety 
of Resources available at each location. 

Resource Group Pane 
Appears at the far left of the screen, below the menu bar. Displays the 
available resources. 
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Resource Name 
Appears in the upper left side of the screen, immediately above the Time 
column. Displays the name of the resource currently active in the client 
window. 

Time 
Appears at the left side of the screen. Times are shown by hour and then by 
segment. They are listed in military time. For example, 13:00 equals 1:00 p.m. 

Title Bar 
Shows user ID and facility location in the upper left corner of the screen.
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Contact Information 

If you have any questions or comments regarding this distribution, contact the OIT 
User Support (IHS) by: 

Phone: (505) 248-4371 or (888) 830-7280 

Fax: (505) 248-4363 

Web: http://www.ihs.gov/GeneralWeb/HelpCenter/Helpdesk/index.cfm 

E-mail: mailto:support@ihs.gov 
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